Author Topic: Failing to Install Soundloom on El Capitain  (Read 2824 times)


  • Newbie
  • *
  • Posts: 1
    • View Profile
Failing to Install Soundloom on El Capitain
« on: January 20, 2016, 08:06:47 PM »
Hi there...and thanks for setting up this Forum.

I do a show on Resonance 104.4 fm involving sound collage, and I'm hoping to get into the CDP in an attempt to take my show to the next level (up until now I've been using Logic X.) I'm running El captain on a 2.7 GHz iMac, Intel Core i5. This is my first experience with using Unix and command-line programming from the Terminal.

I've been attempting to Install Sound Loom with no success. I've downloaded the latest version for Mac from Trevor Wisher's page of Soundloom and release 7.

Whenever I try to launch Soundloom I get the message: "unable to open execloc.cdp to find program path - please check installation"

I've tried following the instructions from the Manualconfig pdf.
~/cdpr7/_cdp/_cdprogs is there in the path and .bash_profile is present, but typing in dirsf or paplay results in the message:

 "-bash: dirsf: command not found"

I've also created the textedit file "launchd.conf. containing the line "setenv  CDP_SOUND_EXT wav" in the Home directory. I've typed

sudo cp launchd.conf /etc

into terminal, entered my password and got this message:

cp: launchd.conf: No such file or directory

I've also tried rebooting after all this with no joy.

cdpr7 and .sloomrc are both present in the home directory.

What am I doing wrong?

with gratitude,

Orlando Harrison


  • Jr. Member
  • **
  • Posts: 6
    • View Profile
Re: Failing to Install Soundloom on El Capitain
« Reply #1 on: December 05, 2017, 06:29:44 AM »
Hi Orlando, this post is so old that you might not ever see this reply but it could still help to serve others.

I was running into the same problem with commands not found.  The problem for me was that CDP was actually installed in a different location.  Most likely the root of your main drive.  is your HDD called 'Macintosh HD'? see if the CDP folder was installed there.  If it was, move it to your user folder and the path should work in that case.
Someone else had a similar problem on the forum which is how i found that fix.  You probably already figured it out for yourself by now anyway.

As far as the launchd.conf file... that needs to be stored in the /etc folder.  The copy to /etc command never worked for me in the terminal. Fortunately there are a number of ways to find that folder with the easiest being to simply type /etc as a spotlight search and double clicking the folder when it pops up as a suggestion.  Then simply copy your launchd.conf text file into there.  It's important to note that that text file should be plaintext and not rich text format.  At least that's what the documentation suggested... I have no idea how important that is if at all.  The way to create a plaintext document is to go into textedit preferences and choose Plain Text as the standard format for a new document.
To be fair I could never get the above to work... I never did find a cdp wav extension listed when I typed env into the terminal.  The sloomrc instructions also never seemed to work so I'm stuck on that too.
« Last Edit: December 05, 2017, 06:31:32 AM by Contact »