Recent Posts

Pages: 1 ... 8 9 [10]
91
I've tracked down where the A.V. occurs, but not why. It's something to do with the initial display of the parameter page when it's re-visited to edit the parameters. The weird thing is it doesn't do it every time -- but every OTHER time, consistently.

However, this gives a workaround: click CANCEL to leave the parameter page and try again (double-click the cell again). This seems to work. A third edit will give another A.V. but the 4th should be OK and so on. You will also get one when you exit the program.

In my searches through the code, I found a different serious bug affecting all processes with >10 parameters, mainly TEXTURE and GRAIN. I've issued an interim .exe correcting this (5.06).

Meanwhile I'll continue to look for the cause of the A.V. You're correct, rotagrad, that the bug also affects TEXTURE DECORATE.  But the same workaround seems to work. Maybe whatever these two have in common will give a clue...
92
Hello, Robert.

Indeed, your description is exactly what I'm having at my end too. After trying to check thoroughly the Texture section, it seems grouped and decorate both show the same access violation issue. I believe I remember having seen this same bug with some other process in the Spectral section in the past as well, so I'll check them today again today, if that is of any help, and report back here later.
93
Thanks for posting this bug. I've verified the problem you mention. I ran Grouped with a single input and the default values. Like you I got the access violation when I went to edit the parameters. I then cancelled and tried again; this time I got the edit boxes but the values were all 0. I also tried recalling a preset and again I got the violation.

Access violations can be quite tricky to track down, but usually occur from impossible values, like accessing a slider value beyond its declared range, for instance. I'll take a close look at the code here and see if I can track down anything sloppy in that regard. The re-setting of values to zero may give a clue. Grouped used to work OK, so I can also compare old code with the current version.

Robert - Author, Soundshaper.
94
Announce / Re: CDP Documentation Updated
« Last post by rotagrad on May 02, 2020, 08:08:35 PM »
Thank you for updating them!
95
PC Installation / SoundShaper "Access Violation" Error When Using TEXTURE GROUP
« Last post by rotagrad on May 02, 2020, 08:06:16 PM »
Hello. I was studying the TEXTURE processes in SoundShaper recently and was enjoying the TEXTURE SIMPLE a lot. I decided to see the other TEXTURE processes, but they have been giving me an error that stops me from using them.

The error happens in SoundShaper specifically when using TEXTURE GROUP. When I place it for the first time in a session of SoundShaper, it works normally. However, if I try to use it again or edit the parameters of it, it shows the following

ACCESS VIOLATION AT ADDRESS 00406AE8 IN MODULE
'SoundShaper.exe'. READ OF ADDRESS 04FFFFF8.

It then does not allow me to change any parameters of TEXTURE GROUP. This error does not happen if I use the CDP Texture process through command line.

Would anyone know something similar to this having happened before? Is there any way of fixing it? I am currently using SoundShaper 5.0 in Windows 10.

I really wanted to explore the texture elements of CDP without having to use the cumbersome method of command lines. Any help is appreciated.
96
General Board / Re: Can't seem to find linux 7.1 binaries?
« Last post by PhotonStorm on April 10, 2020, 03:09:03 PM »
fantastic! I didn't even realise it was on GitHub, I was having a bad time trying to compile the code, so thanks for pointing it out and making my day, hehe now to have some fun with all these sound fragments I have  8)
97
General Board / Re: SoundShaper problem win10 64bit
« Last post by Robert Fraser on April 08, 2020, 09:18:04 AM »
Sonora, Thanks for getting in touch by email and thanks for your patience.

Unfortunately, the problems are still unresolved (at 8 Apr.). The program was not reading the CDP programs folder correctly from the configuration file, despite the fact that the file was correct and the folder was there. It was also not shutting down correctly. Both of these issues need further investigation, though neither has arisen in other installations, as far as I know. While we were exchanging emails, you reported that you had installed Soundshaper successfully on another Win10 computer. I have also tested it recently on 3 Win10 64-bit machines, one Win10 32-bit, one Win7 64-bit and one Win7 32-bit.

The problem may have something to do with the fact that Soundshaper is a 32-bit program running, in this case, on 64-bit Windows. Having said that, Windows automatically runs such programs using its built-in emulator WOW64, so in theory issues should not arise. You also tried running it in Win7 mode, without success. Re-building Soundshaper in native 64-bit would be possible, but could require a lot of work -- I'll look into this.

We will continue to communicate and experiment with other solutions and report back to the forum if we solve the problems.
98
General Board / Re: SoundShaper problem win10 64bit
« Last post by Robert Fraser on April 03, 2020, 09:56:43 PM »
Mario, can you email me with this problem to:  mail [at] ensemble-software.net ? The problem is not likely to be Windows 64-bit or robocopy, so I'll need to get more detail from you and look into this further. I'll be happy to post a reply when we get it fixed.  Robert
99
Announce / CDP Documentation Updated
« Last post by Robert Fraser on April 03, 2020, 09:49:55 PM »
The CDP documentation has been updated today (3rd Apr 2020). The online html docs were already the latest, as were the individual printable pdf versions, but the zip files of both were out-of-date (Aug 2018). Now corrected, with apologies for any inconvenience. The docs are housed at www.ensemble-software.net/CDPDocs

Two changes I would appreciate some help with: SFEDIT ISOLATE in cgroedit.htm has apparently been updated but to my eye it seems the same as in the unchanged sfedit.pdf. Similarly PAPLAY in cmcrefmn.htm / mctoolkit.pdf. Let me know if you can spot any difference(s) :) .
100
General Board / Re: SoundShaper problem win10 64bit
« Last post by sonora on April 02, 2020, 03:39:57 PM »
i copy  robocopy but with no result,missing menu and problem to open program and need to force to close.it seems that it can't mantein the preferences in setting...
Pages: 1 ... 8 9 [10]